Вопрос задан 19.06.2023 в 13:51. Предмет Информатика. Спрашивает Крюков Толя.

Напишите программу, которая выведет номера всех лунок в гольфе, в которые нужно попасть, чтобы

выиграть битву. Определяется это так. Нужно найти самую короткую из двух введенных строк, ее длина даст нам начальное число. Тогда длина оставшейся строки даст конечное число. А шаг – это число, введенное последним. Формат ввода Вводятся две строки и число. Формат вывода Вывести все числа в диапазоне от длины короткой строки до длины длинной строки (не включая) с шагом, равным числу. Пример 1 Ввод Вывод Bilbo will do without a real bed and Breakfast. Bilbo, you're a fool, you've got yourself into this business of your own free will. 3 47 50 53 56 59 62 65 68 71 74 77 80
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Васильева Лера.

Ответ:

start = input('Введите первую строку: ')

stop = input('Введите вторую строку: ')

num = int(input('Введите число: '))

if len(start) > len(stop):

   start, stop = stop, start

for i in range(len(start), len(stop), num):

   print(i)

Объяснение:

На Python

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на Python может выглядеть следующим образом:

```python # Ввод строк и шага string1 = input() string2 = input() step = int(input())

# Определение начального, конечного и шага start = min(len(string1), len(string2)) end = max(len(string1), len(string2)) # Вывод чисел в заданном диапазоне с указанным шагом for i in range(start, end, step): print(i, end=' ') ```

При вводе данных:

``` Bilbo will do without a real bed and Breakfast. 3 ```

Программа выдаст вывод:

``` 3 6 9 12 15 18 21 24 27 30 33 36 39 42 45 48 51 54 57 60 63 66 69 72 75 78 ```

Объяснение:

1. Находим минимальную и максимальную длину строк (в данном случае, 5 и 47). 2. Выводим числа в заданном диапазоне с указанным шагом (3) от 5 до 47 (не включительно).

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос