Вопрос задан 18.06.2023 в 15:33. Предмет Информатика. Спрашивает Акулов Роман.

Питон У Аркадия есть друг Стас. Стас в последнее время часто работал из дома и редко ходил

гулять, зато подписался на страничку с рецептами быстрых пирогов в Инстаграме. История такова: Стас слегка располнел за последний год, поэтому теперь он хочет начать заниматься спортом и вести учёт калорий. Ведь здоровье дороже всего! С клавиатуры вводятся 7 вещественных чисел - количество калорий, съеденных Стасом за последнюю неделю. Нужно считать данные с клавиатуры и записать их в список. Затем вывести на экран при помощи команды: print(список). Формат входных данных С клавиатуры вводятся 7 вещественных чисел. Каждое с новой строки. Формат выходных данных Список.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Печерица Людмила.

Ответ:

Первый вариант решения:

a=float(input())

b=float(input())

c=float(input())

d=float(input())

e=float(input())

f=float(input())

g=float(input())

my_list=[a,b,c,d,e,f,g]

print(my_list)

Второй вариант решения:

my_list=[]

for i in range(7):

   c=float(input())

   my_list.append(c)

print(my_list)

Объяснение:

В первом варианте решения мы просто вводим семь переменных. Потом мы добавляем список (my_list) и ставим [] , так как список так пишется. Вызываем список: print(my_list)

Во втором варианте решения мы пишем название списка(my_list), вводим семь переменных, но уже через for i in range, создаем новую переменную(c=float(input())) , играющую функцию хранилища. Добавляем функцию append (в переводе с английского "добавлять") и прививаем ее к списку с переменной с (my_list.append(c)). Выводим список(print(my_list))

0 0
Отвечает Чернова Алёна.

Ответ:

a = []

for i in range(7):

   x = float(input())

   a.append(x)

print(a)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Запись данных с клавиатуры и вывод списка

Чтобы решить данную задачу, мы можем использовать функцию `input()` для ввода данных с клавиатуры и затем записать их в список. Затем мы можем использовать команду `print()` для вывода списка на экран.

Вот пример кода на языке Python, который решает данную задачу:

```python # Создаем пустой список калории = []

# Вводим 7 вещественных чисел с клавиатуры и добавляем их в список for i in range(7): калория = float(input("Введите количество калорий: ")) калории.append(калория)

# Выводим список на экран print(калории) ```

После запуска этого кода, программа будет запрашивать ввод количества калорий с клавиатуры 7 раз. После ввода всех чисел, программа выведет список на экран.

Пример работы программы:

``` Введите количество калорий: 1500 Введите количество калорий: 1800 Введите количество калорий: 1200 Введите количество калорий: 2000 Введите количество калорий: 1600 Введите количество калорий: 1400 Введите количество калорий: 1700 [1500.0, 1800.0, 1200.0, 2000.0, 1600.0, 1400.0, 1700.0] ```

Таким образом, программа считывает 7 вещественных чисел с клавиатуры, записывает их в список и выводит этот список на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос