НУЖНО: Написать программу ввода, инициализации и вывода массива размерности N (в программе
"Паскаль") где N число букв вашего имени и фамилии без пробела (Например: ИванИванов, значит N=10).Тема: "Одномерные массивы целых чисел. Описание, заполнение, вывод массива."Ответы на вопрос
Программа:
Pascal:
const N = 4;
var i: integer;
arr: array[1..N] of integer;
begin
for i := 1 to N do readln(arr[i]); // ввод массива с клавиатуры
writeln(arr); // вывод массива
end.
const N - задайте сами. По условию нужно написать число букв имени и фамилии.
Вот пример программы на языке программирования Pascal, которая выполняет ввод, инициализацию и вывод одномерного массива целых чисел. В данном случае N равно числу букв в вашем имени и фамилии без пробела:
```pascal program ArrayExample;
const N = 10; // Замените на число букв в вашем имени и фамилии без пробела
var myArray: array[1..N] of integer; i: integer;
// Процедура для ввода элементов массива procedure InputArray; begin writeln('Введите элементы массива:'); for i := 1 to N do begin write('Элемент ', i, ': '); readln(myArray[i]); end; end;
// Процедура для вывода элементов массива procedure OutputArray; begin writeln('Элементы массива:'); for i := 1 to N do write(myArray[i], ' '); writeln; end;
begin InputArray; // Вызываем процедуру ввода OutputArray; // Вызываем процедуру вывода end. ```
Программа определяет массив `myArray` размерности N и содержит две процедуры: `InputArray` для ввода элементов массива и `OutputArray` для вывода элементов массива. В основной программе происходит вызов этих процедур. После ввода массива он выводится на экран.
Вы можете скопировать этот код в среду программирования Pascal (например, Free Pascal) и выполнить программу, заменив значение константы N на количество букв в вашем имени и фамилии без пробела.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
