
Очень срочно, нужно написать программу на паскале, где ты вводишь 5 фамилий и им даётся случайная
оценка от 1 до 5, после нужно вывести фамилии у которых 5

Ответы на вопрос

Ответ:
var
a: array[1..5] of string;
i: integer;
begin
randomize;
for i:= 1 to 5 do readln(a[i]);
writeln('Фамилии с оценкой 5: ');
for i:= 1 to 5 do if random(1,6) = 5 then writeln(a[i])
end.



Конечно, я могу помочь вам написать программу на языке Паскаль, которая будет выполнять требуемую задачу. Вот пример такой программы:
```pascal program RandomGrades;
const MAX = 5;
type TStudent = record LastName: string; FirstName: string; Grade: Integer; end;
var Students: array[1..MAX] of TStudent; i: Integer;
procedure GenerateRandomGrades; begin Randomize; for i := 1 to MAX do Students[i].Grade := Random(5) + 1; end;
procedure InputLastNames; begin for i := 1 to MAX do begin Write('Введите фамилию студента ', i, ': '); Readln(Students[i].LastName); end; end;
procedure DisplayStudentsWithGradeFive; var found: Boolean; begin found := False; for i := 1 to MAX do begin if Students[i].Grade = 5 then begin Writeln(Students[i].LastName); found := True; end; end; if not found then Writeln('Нет студентов с оценкой 5'); end;
begin InputLastNames; GenerateRandomGrades; DisplayStudentsWithGradeFive; end. ```
Эта программа позволит вам ввести 5 фамилий студентов, после чего каждому студенту будет присвоена случайная оценка от 1 до 5. Затем программа выведет фамилии студентов, у которых оценка равна 5.
Обратите внимание, что в данном примере я использовал массив структур `TStudent`, чтобы хранить фамилии и оценки студентов. Программа генерирует случайные оценки с помощью функции `Random`, а затем выводит фамилии студентов с оценкой 5.
Надеюсь, это поможет вам с вашей задачей! Если у вас возникнут еще вопросы, не стесняйтесь задавать.


Похожие вопросы


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili