Вопрос задан 18.06.2023 в 10:34. Предмет Информатика. Спрашивает Васильева Анастасия.

Помогите пожалуйста. В паскале нужно написать программу. В которой нужно отметить дату своего

рождения, сегодняшнюю дату. Нужно чтобы выдало сколько лет мне будет например через 10 лет
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Бабей Александра.

var

 N: integer;

 

begin

 write('N = ');

 readln(N);

 writeln('Возраст: ', 2021 - N)

 writeln('Сегодня: 02.12.2021')

writeln('Например мне через 10: ', 2031 - N)

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу на Pascal, которая вычислит возраст через определенное количество лет. Вот пример программы:

```pascal program CalculateAge;

var birthYear, currentYear, futureYears: Integer; birthMonth, currentMonth, birthDay, currentDay: Integer; ageYears, ageMonths, ageDays: Integer;

begin // Введите дату вашего рождения writeln('Введите год вашего рождения:'); readln(birthYear);

writeln('Введите месяц вашего рождения:'); readln(birthMonth);

writeln('Введите день вашего рождения:'); readln(birthDay);

// Введите текущую дату writeln('Введите текущий год:'); readln(currentYear);

writeln('Введите текущий месяц:'); readln(currentMonth);

writeln('Введите текущий день:'); readln(currentDay);

// Введите количество лет в будущем writeln('Введите количество лет в будущем:'); readln(futureYears);

// Вычислите возраст ageYears := currentYear - birthYear; ageMonths := currentMonth - birthMonth; ageDays := currentDay - birthDay;

// Учтем случаи, когда день или месяц рождения еще не наступил в текущем году if ageMonths < 0 then begin ageYears := ageYears - 1; ageMonths := ageMonths + 12; end;

if ageDays < 0 then begin ageMonths := ageMonths - 1; ageDays := ageDays + 30; // предполагаем, что в месяце 30 дней end;

// Увеличиваем возраст на указанное количество лет в будущем ageYears := ageYears + futureYears;

// Выводим результат writeln('Через ', futureYears, ' лет вам будет ', ageYears, ' лет.'); end. ```

Пожалуйста, обратите внимание, что в данном примере предполагается, что месяц имеет 30 дней. Вы можете внести соответствующие изменения в код, чтобы учесть разные количество дней в месяцах.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос