СРОЧНО!!! напиши на Паскале программу поиска суммы отрицательных чисел СРОЧНО!!!
Ответы на вопрос
Ответ:
Sum:=0;
for i:=1 to 10 do
if B[i]<0 then Sum:=Sum+B[i];
Объяснение:вроде так если не ошибаюсь
Я могу помочь вам написать программу на Паскале, которая ищет сумму отрицательных чисел в массиве. Вот пример такой программы:
```pascal program SumOfNegativeNumbers; var a: array[1..10] of integer; // объявляем массив из 10 целых чисел i, sum: integer; // объявляем переменные для индекса и суммы begin sum := 0; // инициализируем сумму нулем for i := 1 to 10 do // цикл по элементам массива begin readln(a[i]); // считываем очередной элемент массива с клавиатуры if a[i] < 0 then // если элемент отрицательный sum := sum + a[i]; // добавляем его к сумме end; writeln('Сумма отрицательных чисел равна ', sum); // выводим сумму на экран end. ```
Надеюсь, это поможет вам решить вашу задачу. Удачи!
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
