Составьте программу,которая формирует массив из двенадцати случайных целых чисел,принадлежащих
провежутку [4;5],и выводит эти числа в столбец. 9 класс ПаскальОтветы на вопрос
Программа:
Pascal:
var
arr: array[1..12] of integer;
begin
for var i := 1 to 12 do arr[i] := random(4,5);
arr.print(newline);
end.
Вот пример программы на языке Паскаль, которая формирует массив из двенадцати случайных целых чисел в диапазоне от 4 до 5 и выводит эти числа в столбец:
```pascal program RandomArray;
var arr: array[1..12] of Integer; i: Integer;
begin Randomize; // Инициализация генератора случайных чисел
// Заполнение массива случайными числами for i := 1 to 12 do begin arr[i] := Random(2) + 4; // Генерация случайного числа от 4 до 5 end;
// Вывод чисел в столбец for i := 1 to 12 do begin writeln(arr[i]); end;
readln; end. ```
В этой программе используется генератор случайных чисел `Randomize`, который инициализирует генератор случайных чисел в зависимости от текущего времени. Затем массив `arr` размером 12 элементов заполняется случайными числами от 4 до 5 с помощью функции `Random(2) + 4`. Затем числа выводятся в столбец с помощью цикла `for` и процедуры `writeln`.
Примечание: Программа будет генерировать новый набор случайных чисел каждый раз при запуске.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
