
Написать программу: Сформировать одномерный массив, где элементы массива - целые числа в пределах
от -10 до 10. Найти максимальный элемент в массиве.

Ответы на вопрос

var
a:array of integer;
i,n,max:integer;
begin
write('Кол-во эл. в массиве: '); readln(n);
max:=-20;
setlength(a,n);
for i:=0 to n-1 do
begin
a[i]:=random(21)-10;
write(a[i],' ');
if a[i]>max then
max:=a[i];
end;
writeln;
writeln('Max: ',max);
end.



Program to Find the Maximum Element in an Array
Here's a program in C that generates a one-dimensional array with elements ranging from -10 to 10 and finds the maximum element in the array:
```c
#include
int main() { int arr[21]; // Array with 21 elements (-10 to 10) int i, max;
// Generate the array for (i = 0; i < 21; i++) { arr[i] = i - 10; }
// Find the maximum element max = arr[0]; for (i = 1; i < 21; i++) { if (arr[i] > max) { max = arr[i]; } }
// Print the maximum element printf("The maximum element in the array is: %d\n", max);
return 0; } ```
This program initializes an array `arr` with 21 elements ranging from -10 to 10. It then iterates through the array to find the maximum element using a variable `max`. Finally, it prints the maximum element.
Please note that the array size is fixed at 21 to accommodate the range from -10 to 10. The program assumes that you are looking for the maximum element in this specific array.
Let me know if you have any further questions!


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili