Вопрос задан 17.06.2023 в 22:21. Предмет Информатика. Спрашивает Узакбай Динара.

С клавиатуры вводится число N, а затем массив из N целых чисел. Определить минимальное и

максимальное среди двузначных чисел, которые делятся на 3. Если таких чисел не было, вывести "нет". СРОЧНО ПОМОГИТЕ, ДАМ 15 БАЛЛОВ*язык программирования Python
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Мишин Михаил.

Программа:

Python:

import sys

max, min = -(sys.maxsize), sys.maxsize

c = 0

N = int(input('N = '))

print('Введите массив:')

arr = [int(input()) for i in range(N)]

for i in arr:

   if len(str(i)) == 2 and i % 3 == 0:

       if i < min:  min = i

       elif i > max:  max = i

if max != -(sys.maxsize):  print('Максимальное число:', max)

else: print('Нет максимального числа')

if min != (sys.maxsize):  print('Минимальное число:', min)

else: print('Нет минимального числа')

Pascal:

var

 arr: array of integer;

 N, i, max, min, j, c: integer;

procedure Symv(j: integer; var c: integer);

begin

 while j > 0 do begin

   j := j div 10;

   c += 1;

 end;

end;

begin

 max := -MAXINT;

 min := MAXINT;

 write('N = ');  readln(N);

 SetLength(arr, N);

 writeln('Введите элементы массива:');

 for i := 0 to N - 1 do readln(arr[i]);

 writeln(arr);

 

 for i := 0 to N - 1 do begin

   Symv(arr[i], c);

   if (c = 2) and (arr[i] mod 3 = 0) then begin

     if arr[i] < min then min := arr[i]

     else if arr[i] > max then max := arr[i]

   end;

   c := 0;

 end;

 

 if max <> -MAXINT then writeln('Максимальное число: ', max)

 else writeln('Нет максимального числа.');

 if min <> MAXINT then writeln('Минимальное число: ', min)

 else writeln('Нет минимального числа.');

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи нахождения минимального и максимального двузначного числа, которое делится на 3, вам потребуется написать программу на языке программирования Python. Вот пример решения:

```python def find_min_max_divisible_by_3(numbers): min_num = float('inf') max_num = float('-inf')

for num in numbers: if 10 <= num <= 99 and num % 3 == 0: min_num = min(min_num, num) max_num = max(max_num, num)

if min_num == float('inf') or max_num == float('-inf'): return "нет" else: return min_num, max_num

# Пример использования n = int(input("Введите число N: ")) array = [] for i in range(n): num = int(input(f"Введите целое число {i+1}: ")) array.append(num)

result = find_min_max_divisible_by_3(array) print(result) ```

В этом примере мы сначала определяем функцию `find_min_max_divisible_by_3`, которая принимает массив чисел и находит минимальное и максимальное двузначное число, которое делится на 3. Затем мы запрашиваем у пользователя число N и массив из N целых чисел. После этого вызываем функцию `find_min_max_divisible_by_3` и выводим результат.

Обратите внимание, что в приведенном коде необходимо самостоятельно обработать ввод чисел и проверить их на соответствие условиям (двузначность и деление на 3). Также обратите внимание, что в примере используется функция `input()` для ввода данных с клавиатуры.

Надеюсь, это поможет вам решить задачу! Если у вас возникнут дополнительные вопросы, пожалуйста, дайте мне знать.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос