Pascal ABC Создать массив из 10 случайных чисел из интервала (-125;60].Написать программу
нахождения:1) Наименьшего элемента массива и его номера;2) Наименьшего элемента массива, кратного 6, и его номера.3) Наибольшего чётного элемента массива.Ответы на вопрос
Программа:
Pascal:
var arr: array[1..10] of integer;
i, min, minINDEX, minSIX, minSIXindex, max: integer;
begin
min := MAXINT; minSIX := MAXINT; max := -MAXINT;
for i := 1 to 10 do begin
arr[i] := random(-124, 60);
if arr[i] < min then begin
min := arr[i];
minINDEX := i;
end;
if (arr[i] mod 6 = 0) and (arr[i] < minSIX) then begin
minSIX := arr[i];
minSIXindex := i;
end;
if (arr[i] mod 2 = 0) and (arr[i] > max) then max := arr[i]
end;
writeln(arr);
writeln('Наименьший элемент массива: ', min, ', индекс: ', minINDEX);
writeln('Наименьший элемент массива, кратный 6: ', minSIX, ', индекс: ', minSIXindex);
writeln('Наибольший чётный элемент массива: ', max);
end.
Конечно, вот пример программы на Pascal ABC, который создает массив из 10 случайных чисел в интервале (-125;60] и находит указанные значения:
```pascal program ArrayOperations;
const N = 10; // Размер массива
var arr: array[1..N] of integer; // Объявление массива i, minElem, minElem6, maxEvenElem, minElemIndex, minElem6Index, maxEvenElemIndex: integer;
begin // Инициализация генератора случайных чисел Randomize;
// Заполнение массива случайными числами в интервале (-125;60] for i := 1 to N do arr[i] := Random(186) - 125;
// Вывод массива writeln('Массив:'); for i := 1 to N do write(arr[i], ' ');
// Нахождение наименьшего элемента и его номера minElem := arr[1]; minElemIndex := 1; for i := 2 to N do begin if arr[i] < minElem then begin minElem := arr[i]; minElemIndex := i; end; end; writeln; writeln('1) Наименьший элемент массива: ', minElem); writeln(' Номер элемента: ', minElemIndex);
// Нахождение наименьшего элемента, кратного 6, и его номера minElem6 := MaxInt; minElem6Index := -1; for i := 1 to N do begin if (arr[i] mod 6 = 0) and (arr[i] < minElem6) then begin minElem6 := arr[i]; minElem6Index := i; end; end; writeln; writeln('2) Наименьший элемент массива, кратный 6: ', minElem6); writeln(' Номер элемента: ', minElem6Index);
// Нахождение наибольшего четного элемента и его номера maxEvenElem := -MaxInt; maxEvenElemIndex := -1; for i := 1 to N do begin if (arr[i] mod 2 = 0) and (arr[i] > maxEvenElem) then begin maxEvenElem := arr[i]; maxEvenElemIndex := i; end; end; writeln; writeln('3) Наибольший четный элемент массива: ', maxEvenElem); writeln(' Номер элемента: ', maxEvenElemIndex);
end. ```
Программа создает массив, выводит его содержимое, затем находит наименьший элемент, наименьший элемент, кратный 6, и наибольший четный элемент, выводя соответствующие значения и их индексы в массиве.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
