Вопрос задан 17.06.2023 в 19:02. Предмет Информатика. Спрашивает Овчинникова Лера.

Реверс массива Напишите программу, которая выполняет реверс массива: меняет местами первый и

последний элементы, второй и предпоследний и т.д. Входные данные Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 . Выходные данные Программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами. Примеры входные данные: 6 1 2 3 4 5 6 выходные данные: 6 5 4 3 2 1 ОБЯЗАТЕЛЬНО c++
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ростованов Влад.

Відповідь:

#include<iostream>

int main(){

int N;

std::cin>>N;

int* massif = new int[N];

for(int i=0;i<N;i++) std::cin>>massif[i];

for(int i=N-1;i>=0;i--) std::cout<<massif[i]<<" ";

delete[]massif;

 

}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на C++, которая выполняет реверс массива:

```cpp #include #include

int main() { int N; std::cin >> N;

std::vector array(N); for (int i = 0; i < N; i++) { std::cin >> array[i]; }

for (int i = 0; i < N / 2; i++) { int temp = array[i]; array[i] = array[N - 1 - i]; array[N - 1 - i] = temp; }

for (int i = 0; i < N; i++) { std::cout << array[i] << " "; }

return 0; } ```

Программа сначала считывает размер массива `N` из первой строки. Затем она считывает `N` чисел из второй строки и сохраняет их в массиве. Далее, программа выполняет реверс массива, меняя местами первый и последний элементы, второй и предпоследний и так далее. Наконец, программа выводит получившийся массив в одну строку, разделяя элементы пробелами.

Например, для входных данных `6 1 2 3 4 5 6`, программа выведет `6 5 4 3 2 1`.

Примечание: Данная программа написана на языке C++. Если у вас возникнут вопросы по другим языкам программирования, пожалуйста, уточните это.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос