Вопрос задан 19.10.2018 в 08:50. Предмет Информатика. Спрашивает Купяк Маша.

Помогите пож в С++ Напишите программу, которая выполняет реверс массива: меняет местами первый и

последний элементы, второй и предпоследний и т.д. Входные данные Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 . Выходные данные Программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Балезина Валерия.
#include <iostream>
using namespace std;
int main()
{
  int n,i;
  cin >> n;
  int a[n];
  for (i = 1; i <= n; i++)
    cin >> a[i];
  for (i = n; i > 0; i--)
    cout << a[i] << " ";
}
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа может быть написана на языке программирования C++.

```cpp #include #include

int main() { int n; std::cin >> n; std::vector array(n); for(int i = 0; i < n; i++) { std::cin >> array[i]; } for(int i = 0; i < n / 2; i++) { int temp = array[i]; array[i] = array[n - 1 - i]; array[n - 1 - i] = temp; } for(int i = 0; i < n; i++) { std::cout << array[i] << " "; } return 0; } ```

Программа считывает размер массива из первой строки и создает вектор array с заданным размером. Затем во второй строке считываются элементы массива. Далее происходит обмен элементов массива следующим образом: первый элемент меняется местами с последним, второй элемент - с предпоследним и т.д. В конце программа выводит элементы получившегося массива на одной строке, разделенные пробелами.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос