Вопрос задан 29.06.2018 в 21:44.
Предмет Информатика.
Спрашивает Аникин Иван.
Напишите программу, которая вычисляет факториал натурального числа N ( 1 ≤ N ≤ 10000 ), сохранив
все значащие цифры. Факториалом называется произведение всех натуральных чисел от 1 до N : N ! = 1·2·3... ( N - 1)· N . Входные данные Входная строка содержит натуральное число N ( 1 ≤ N ≤ 10000 ). Выходные данные Программа должна вывести факториал числа N . Примеры входные данные 6 выходные данные 720 Pascal ABC 1.8Ответы на вопрос
Отвечает Кунилов Даниил.
//PascalABC.NET 3.2, старой версии нет, не могу проверить
begin
var a: BigInteger := 1;
for var i := 1 to ReadInteger do
a *= i;
write(a)
end.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 33
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
