Вопрос задан 17.06.2023 в 05:26. Предмет Информатика. Спрашивает Лисицина Анастасия.

Помогите пж!!! Это работа в Питоне (Python)1) Постройте и запишите в виде программы алгоритм

вычисления суммы квадратов 10 произвольных чисел, вводимых с клавиатуры в процессе выполнения программы.Следующее задание 2) Напишите программу вычисления количества цифр в заданном натуральном числе.Еще одно задание3) Напишите программу вычисления суммы чисел, введенных с клавиатуры, пока сумма не превысит 1000.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Клюшина Оля.

#1

sum = 0

for i in range(10):

   num = int(input())

   sum += num**2

print(sum)

#########

#2

num = int(input())

lenth = len(str(num))

print(lenth)

#########

#3

num = int(input())

sum = 0

while sum + num <= 1000:

   sum += num

   num = int(input())

print(sum)

#########




0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Алгоритм вычисления суммы квадратов 10 произвольных чисел

Для вычисления суммы квадратов 10 произвольных чисел, вводимых с клавиатуры, можно использовать следующий алгоритм в Python:

1. Создайте переменную `sum_of_squares` и установите ее значение равным 0. Эта переменная будет использоваться для накопления суммы квадратов чисел. 2. Используйте цикл `for` для получения 10 чисел от пользователя с помощью функции `input()`. Внутри цикла преобразуйте введенное значение в целое число с помощью функции `int()`. 3. Внутри цикла добавьте к переменной `sum_of_squares` квадрат текущего числа, используя оператор `**`. 4. После завершения цикла выведите значение переменной `sum_of_squares`.

Пример программы:

```python sum_of_squares = 0 for _ in range(10): num = int(input("Введите число: ")) sum_of_squares += num ** 2

print("Сумма квадратов чисел:", sum_of_squares) ```

Примечание: В данном примере используется символ `_` вместо переменной, так как значение не используется внутри цикла.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос