Вопрос задан 16.06.2023 в 15:00. Предмет Информатика. Спрашивает Литвинов Никита.

Срочно питон. Напишите программу 4. Ввести три числа, вывести их в порядке возрастания: сначала

меньшее, затем среднее, затем большее. В качестве ответа программа должна вывести сначала меньшее, затем - через пробел среднее, затем - через пробел большее. Указание. Среднее число можно вычислить как сумму трех чисел минус максимум и минус минимум.​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Матюнина Алиса.

Ответ:

a, b, c = map(int, input().split()) #ввод с клавиатуры

print(f"Результат №1: {' '.join(map(str,sorted([a,b,c])))}") # Решение в строку

# Второй вариант решения (как в указании)

min, max = b, b

if a < b:

 if a < c: min = a

 else: min = c

elif a > c:

 max = a

else: max = c

print(f"Результат №2: {min} {a+b+c-min-max} {max}")

Объяснение:

Написал вам два варианта решения)


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке Python, которая выполняет указанную задачу:

```python def sort_numbers(a, b, c): minimum = min(a, b, c) maximum = max(a, b, c) middle = a + b + c - minimum - maximum

return minimum, middle, maximum

# Ввод чисел num1 = int(input("Введите первое число: ")) num2 = int(input("Введите второе число: ")) num3 = int(input("Введите третье число: "))

# Сортировка и вывод чисел result = sort_numbers(num1, num2, num3) print("Числа в порядке возрастания:", result[0], result[1], result[2]) ```

В этой программе мы определяем функцию `sort_numbers`, которая принимает три числа в качестве аргументов и возвращает кортеж с тремя числами, отсортированными в порядке возрастания.

Затем мы запрашиваем у пользователя ввод трех чисел и сохраняем их в переменные `num1`, `num2` и `num3`.

Далее мы вызываем функцию `sort_numbers` с введенными числами и сохраняем результат в переменную `result`. Наконец, мы выводим отсортированные числа, разделенные пробелом.

Примечание: В этой программе мы предполагаем, что пользователь будет вводить только целые числа. Если вам нужно обрабатывать числа с плавающей точкой, вам придется изменить тип данных вводимых переменных и соответствующим образом изменить код.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос