
Написать программу оптимальный вес информатика тема if else


Ответы на вопрос

Ответ:
Var x:integer;
Begin
Writeln ('введите вес') ;
Readln (x)
If (x>25) and (x<85) then Writeln ('оптимальный вес')
Else Writeln ('не оптимальный вес') ;
End.
Объяснение:
Можно место значений 25 и 85 подставить другие.



Конечно! Вот пример программы на языке Python, которая поможет определить оптимальный вес в зависимости от роста и пола:
python# Ввод данных
рост = float(input("Введите рост в сантиметрах: "))
пол = input("Введите пол (м/ж): ")
# Определение оптимального веса
if пол == "м":
оптимальный_вес = (рост - 100) * 0.9
elif пол == "ж":
оптимальный_вес = (рост - 110) * 0.9
else:
оптимальный_вес = 0
print("Некорректно указан пол. Попробуйте еще раз.")
# Вывод результата
if оптимальный_вес > 0:
print("Оптимальный вес:", оптимальный_вес, "кг")
В этой программе мы сначала запрашиваем у пользователя рост в сантиметрах и пол (символ "м" для мужчин и "ж" для женщин). Затем, используя условные операторы if-elif-else, мы определяем оптимальный вес в зависимости от пола и роста. Если указан некорректный пол, программа выведет сообщение об ошибке. В конце выводится оптимальный вес только в случае, если он положительный.
Помните, что это всего лишь пример программы. Реальный оптимальный вес зависит от множества факторов, и эта программа предоставляет только простой расчет. Всегда стоит обратиться к медицинским специалистам для получения точной информации о здоровье и оптимальном весе.


Похожие вопросы
Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili