
Помогите написать программу в Pascal, уже несколько часов мучаюсь и не могу написать программу,
чтобы он посчитал сколько букв "а"

Ответы на вопрос

Ответ:
Program qq;
Var c, i: integer;
s: string;
Begin
Readln(s);
For i:=1 to length(s) do
If s[i] = 'a' then
Inc(c) ;
Writeln(a) ;
End.



Конечно, я могу помочь вам написать программу на языке Pascal, которая будет считать количество букв "а" в заданной строке. Вот пример программы:
```pascal program CountLetterA; var str: string; count: integer; i: integer; begin writeln('Введите строку:'); readln(str); count := 0; for i := 1 to length(str) do begin if (str[i] = 'a') or (str[i] = 'A') then count := count + 1; end; writeln('Количество букв "а" в строке: ', count); readln; end. ```
В этой программе мы сначала объявляем переменные: `str` для хранения введенной строки, `count` для подсчета количества букв "а" и `i` для итерации по символам строки.
Затем мы считываем строку от пользователя с помощью `readln` и устанавливаем начальное значение `count` равным 0.
Далее мы используем цикл `for` для перебора всех символов строки. Внутри цикла мы проверяем, равен ли текущий символ "а" или "А", и если да, то увеличиваем значение `count` на 1.
После окончания цикла выводим результат подсчета с помощью `writeln`.
Теперь вы можете запустить эту программу на вашем компьютере, и она будет считать количество букв "а" в введенной вами строке. Надеюсь, это поможет вам решить вашу задачу! Если у вас возникнут еще вопросы, не стесняйтесь задавать.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili