Вопрос задан 16.06.2023 в 11:06. Предмет Информатика. Спрашивает Чернушкин Роман.

Питон 1. Напишите программу, которая получает с клавиатуры натуральное число N и в его десятичной

записи находит сумму цифр, делящихся на 3. Ноль тоже делится на 3.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Захарова Ольга.

Ответ:

Объяснение:

N=int(input())

sum=0

for i in range(N):

   if i%3==0:

       sum+=i

print(sum)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа для нахождения суммы цифр, делящихся на 3

Для решения данной задачи, напишем программу на языке Python, которая будет получать с клавиатуры натуральное число N и находить сумму цифр, делящихся на 3 в его десятичной записи. Ноль также считается делящимся на 3.

```python N = int(input("Введите натуральное число: ")) # Получаем число N с клавиатуры

# Инициализируем переменную для хранения суммы цифр, делящихся на 3 sum_of_digits = 0

# Проходим по каждой цифре числа N for digit in str(N): if int(digit) % 3 == 0: # Проверяем, делится ли цифра на 3 sum_of_digits += int(digit) # Если да, то добавляем ее к сумме

# Выводим результат print("Сумма цифр, делящихся на 3:", sum_of_digits) ```

Пример работы программы: ``` Введите натуральное число: 123456789 Сумма цифр, делящихся на 3: 18 ```

Таким образом, данная программа позволяет получить с клавиатуры натуральное число N и находит сумму цифр, делящихся на 3 в его десятичной записи.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос