Вопрос задан 16.06.2023 в 09:30. Предмет Информатика. Спрашивает Махмудова Кристина.

Написать программу на питоне! В данном упражнении вы должны написать программу для подсчета

среднего значения всех введенных пользователем чисел. Индикатором окончания ввода будет служить ноль. При этом программа должна выдавать соответствующее сообщение об ошибке, если первым же введенным пользователем значением будет ноль. Примечания А. Поскольку ноль является индикатором окончания ввода, его не нужно учитывать при расчете среднего. Б. Решить поставленную задачу при условии, что исходные числа будут задаваться генератором случайных чисел
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Малахова Елена.

num = float(input())

if(num == 0):

   print("Error")

   exit(0)

sum = 0

amount = 0

while num != 0:

   sum += num

   amount += 1

   num = float(input())

print("Average:", sum / amount)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на Python, которая выполняет задачу подсчета среднего значения введенных пользователем чисел с использованием генератора случайных чисел:

python
import random numbers = [] while True: num = random.randint(1, 100) # Генерируем случайное число от 1 до 100 print("Сгенерировано число:", num) if num == 0: if len(numbers) == 0: print("Ошибка: первым введенным числом был ноль.") break else: break numbers.append(num) if len(numbers) > 0: average = sum(numbers) / len(numbers) print("Среднее значение:", average) else: print("Не было введено ни одного числа.")

Программа генерирует случайное число от 1 до 100 на каждой итерации цикла. Если сгенерированное число равно 0, программа проверяет, было ли введено хотя бы одно число. Если введенное число было нулем и оно было первым числом, программа выводит сообщение об ошибке. В противном случае, программа вычисляет среднее значение введенных чисел (исключая 0) и выводит его.

Пожалуйста, обратите внимание, что в этом примере используется модуль random для генерации случайных чисел. Вы можете импортировать его, добавив import random в начало вашей программы.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос