Вопрос задан 16.06.2023 в 07:54. Предмет Информатика. Спрашивает Власенков Егор.

Напишите программу которая построит таблицу умножения 3*3 в виде прямоугольника

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кузьмина Екатерина.

#Способ 1     - просто форматный вывод

print('1 2 3')

print('2 4 6')

print('3 6 9')

#Способ 2  - с расчётом матрицы

a=[]

for i in range(1,4):

   b=[]

   for j in range(1,4):

       b.append(i*j)

   a.append(b)  

   print(*a[i-1])

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Я могу помочь вам с написанием программы, которая построит таблицу умножения 3*3 в виде прямоугольника. Вот один из возможных вариантов решения этой задачи на языке Python:

```python # Вводим число n, которое определяет размер таблицы n = int(input("Введите число n: "))

# Создаем двойной цикл для перебора строк и столбцов таблицы for i in range(1, n + 1): # Цикл для строк for j in range(1, n + 1): # Цикл для столбцов # Выводим произведение i и j с разделителем табуляции print(i * j, end="\t") # Переходим на новую строку после каждой строки таблицы print() ```

Этот код выводит на экран таблицу умножения 3*3 в следующем виде:

``` 1 2 3 2 4 6 3 6 9 ```

Вы можете найти больше примеров и объяснений по этой теме на сайтах [Stack Overflow] или [Habr]. Надеюсь, что это было полезно для вас. Спасибо за использование Bing!

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос