
Составить программу, вычисляющую количество элементов двумерного массива, размерности 3 на 4,
больших заданного числа.. паскаль

Ответы на вопрос

Программа:
Pascal:
var
arr: array[1..3, 1..4] of integer;
i, j, n, count: integer;
begin
write('Введите число: '); readln(n); // ввод числа n
for i := 1 to 3 do
for j := 1 to 4 do begin
arr[i, j] := random(100); // заполнение массива случайными числами от 0 до 100
if arr[i, j] > n then // если число больше заданного числа, то...
count += 1; // увеличиваем значение переменной count на 1
end;
writeln('Массив: ', arr); // вывод массива
writeln('Чисел, больше ', n, ': ', count); // вывод кол-ва элементов, больше n.
end.
Чтобы заполнить массив, для начала нужно выделить ему память. После этого запрашивает значение "заданного числа" n. После выделения памяти и запроса числа нужно в двойном цикле обойти все ячейки массива (i - номер строки, j - номер столбца). После начала цикла сначала заполняем массив случайными числами (от 0 до 100), а после находим количество элементов, больше заданного числа. В конце выводим сам массив и кол-во элементов, больше заданного числа.



Вот пример программы на языке Pascal, которая вычисляет количество элементов двумерного массива размерности 3 на 4, больших заданного числа:
```pascal program CountElements; var arr: array[1..3, 1..4] of integer; num: integer; count: integer; i, j: integer; begin count := 0; // Ввод элементов массива for i := 1 to 3 do begin for j := 1 to 4 do begin write('Введите элемент arr[', i, '][', j, ']: '); readln(arr[i, j]); end; end; // Ввод заданного числа write('Введите заданное число: '); readln(num); // Подсчет количества элементов больших заданного числа for i := 1 to 3 do begin for j := 1 to 4 do begin if arr[i, j] > num then count := count + 1; end; end; // Вывод результата writeln('Количество элементов массива, больших заданного числа: ', count); end. ```
Программа запрашивает у пользователя ввод элементов двумерного массива размерности 3 на 4 и заданного числа. Затем она подсчитывает количество элементов массива, которые больше заданного числа, и выводит результат.
Примечание: Приведенный выше код является примером и может быть изменен или доработан в соответствии с требованиями вашей задачи или окружения разработки.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili