
Код в паскаль СРОЧНО! Человек вложил 100 000 рублей под 4% в месяц. Успеет ли он накопить на
машину стоимостью 2 700 000 за 6,5 лет. С вводом данных с клавиатуры

Ответы на вопрос

Ответ:
Не, не получится накопить
Объяснение:
program kopilka;
uses crt;
var x, c, p, y:real; i, m:integer;
begin
clrscr;
write ('Введите начальную сумму вклада, рублей: ') ;
readln(x);
write ('Введите желаемую сумму накопления, рублей: ') ;
readln(c);
write ('Введите срок накопления, лет: ') ;
readln(y);
m:=round(y*12);
write ('Введите ежемесячно начисляемый процент (%) : ') ;
readln(p); p:=p/100;
for i:=1 to m do
x:=x+x*p;
if x<c then write('Вы накопили ',x:6:2,' рублей, это меньше запланнированной суммы в ',c:6:2,' рублей')
else write('Ваша цель по накоплению ',c:6:2,' рублей достигнута: вы накопили ',x:6:2,' рублей') ;
readln;
end.




Для решения данной задачи, мы можем использовать формулу сложных процентов. Формула для расчета суммы накопления по сложным процентам выглядит следующим образом:
A = P(1 + r/n)^(nt)
Где: - A - сумма накопления - P - начальная сумма вложения - r - годовая процентная ставка (в десятичной форме) - n - количество раз, когда проценты начисляются в год - t - количество лет
В данном случае, начальная сумма вложения (P) составляет 100 000 рублей, годовая процентная ставка (r) равна 4% (или 0.04 в десятичной форме), количество раз начисления процентов в год (n) равно 12 (так как проценты начисляются ежемесячно), и количество лет (t) равно 6.5.
Теперь мы можем подставить значения в формулу и рассчитать сумму накопления (A):
A = 100000(1 + 0.04/12)^(12*6.5)
Вычислив данное выражение, мы получим сумму накопления за 6.5 лет. Однако, для удобства пользователя, мы можем написать программу на языке Pascal, которая позволит вводить данные с клавиатуры и автоматически рассчитывать результат.
```pascal program SavingsCalculator;
var P, A, r, n, t: real;
begin writeln('Введите начальную сумму вложения (P): '); readln(P); writeln('Введите годовую процентную ставку (r): '); readln(r); writeln('Введите количество раз начисления процентов в год (n): '); readln(n); writeln('Введите количество лет (t): '); readln(t); A := P * power(1 + r/n, n*t); writeln('Сумма накопления (A) за ', t, ' лет составит: ', A:0:2, ' рублей'); end. ```
После запуска программы, она будет запрашивать ввод данных с клавиатуры и выводить результат на экран.
Примечание: Для выполнения данной программы, вам понадобится среда разработки Pascal, такая как Free Pascal или Turbo Pascal.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili