Вопрос задан 15.06.2023 в 15:48. Предмет Информатика. Спрашивает Грозная Настя.

Программисты вы тут ? Помогите :3 Питон 1. Напишите программу на Python для суммирования всех

элементов в списке. 2. Напишите программу на Python, чтобы получить наибольшее число из списка.​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Коновальчук Юлія.

Ответ:

дубль 2

Объяснение:

1.

a=list(map(int, input().split()))

x=0

for i in range(len(a)):

  x+=a[i]

print(x)

2.

a=list(map(int, input().split()))

print(max(a))

или

a=list(map(int, input().split()))

x=-10000

for i in range(len(a)):

  if x<a[i]:

      x=a[i]

print(x)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам с программированием на Python! Вот решения для ваших двух задач:

1. Напишите программу на Python для суммирования всех элементов в списке:

```python def sum_list_elements(lst): total = 0 for element in lst: total += element return total

# Пример использования: my_list = [1, 2, 3, 4, 5] result = sum_list_elements(my_list) print("Сумма элементов в списке:", result) ```

В этом примере мы определяем функцию `sum_list_elements`, которая принимает список в качестве аргумента. Затем мы создаем переменную `total`, которая будет хранить сумму элементов. Затем мы проходимся по каждому элементу списка с помощью цикла `for` и добавляем его к переменной `total`. Наконец, мы возвращаем общую сумму.

2. Напишите программу на Python, чтобы получить наибольшее число из списка:

```python def get_max_number(lst): max_number = lst[0] for element in lst: if element > max_number: max_number = element return max_number

# Пример использования: my_list = [10, 5, 20, 8, 15] result = get_max_number(my_list) print("Наибольшее число в списке:", result) ```

В этом примере мы определяем функцию `get_max_number`, которая принимает список в качестве аргумента. Затем мы создаем переменную `max_number`, которая будет хранить наибольшее число и инициализируем ее первым элементом списка. Затем мы проходимся по каждому элементу списка с помощью цикла `for` и сравниваем его с переменной `max_number`. Если текущий элемент больше `max_number`, мы обновляем значение `max_number`. Наконец, мы возвращаем наибольшее число.

Примечание: Если ваш список пустой, эти программы могут вызвать ошибку. Убедитесь, что ваш список содержит хотя бы один элемент перед его использованием.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос