Вопрос задан 15.06.2023 в 14:51. Предмет Информатика. Спрашивает Кагаров Егор.

1-Напишите программу в питоне, которая получает на вход текст и проверяет заканчивается ли оно на

"s". 2-Напишите программу в питоне, которая получает на вход слово и проверяет равна ли вторая и предпоследние буквы в нём.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кубряк Сергей.

1.

a = input()

if a[len(a) - 1] == 's':

   print('Да')

else:

   print('Нет')

2.

a = input()

if a[1] == a[len(a) - 2]:

   print('Да')

else:

   print('Нет')

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Проверка окончания текста на "s" в Python

Для проверки, заканчивается ли текст на "s" в Python, можно написать следующую программу:

```python def check_ends_with_s(text): if text.endswith('s'): return True else: return False

# Пример использования input_text = "This is a test" result = check_ends_with_s(input_text) print(result) ```

Этот код определяет функцию `check_ends_with_s`, которая принимает текст в качестве аргумента и возвращает `True`, если текст заканчивается на "s", и `False` в противном случае.

Проверка равенства второй и предпоследней букв в слове в Python

Для проверки равенства второй и предпоследней букв в слове в Python, можно использовать следующую программу:

```python def check_second_and_penultimate_letters(word): if len(word) >= 2 and word[-2] == word[1]: return True else: return False

# Пример использования input_word = "hello" result = check_second_and_penultimate_letters(input_word) print(result) ```

Этот код определяет функцию `check_second_and_penultimate_letters`, которая принимает слово в качестве аргумента и возвращает `True`, если вторая и предпоследняя буквы равны, и `False` в противном случае.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос