
Составьте программу Паскаль ( даю 66 баллов) 1) Дан массив 10 целых чисел. Найти количество
нечётных чисел. 2) Дан массив из 20 целых чисел. Все отрицательные элементы массива заменить на 0 и вывести полученный массив на экран.

Ответы на вопрос

Ответ:
var
i, n: integer; // объявляем переменные целочисленного типа.
arr: array [1..10] of integer; // объявляем массив, размерностью 10.
s : string; // объявление переменной строкового типа.
begin
for i := 1 to 10 do // начало цикла.
begin
arr[i] := random(0, 20); // заполняем элемент массива числом из диапазона 0; 20.
s := s + inttostr (arr[i])+ ' '; // записываем массив в одну строку.
if (arr[i] mod 2 <> 0) then n := n + 1; // считаем количество нечетных элементов.
end;
writeln ('Исходный массив: ', s); // вывод исходного массива на экран.
writeln('Количество нечетных элементов в массиве равно: ', n); // вывод строки на экран.
end.



Программа на языке Паскаль для выполнения задач:
1) Дан массив 10 целых чисел. Найти количество нечётных чисел.
```pascal program OddNumbers; var arr: array[1..10] of integer; i, count: integer; begin count := 0; for i := 1 to 10 do begin readln(arr[i]); if arr[i] mod 2 <> 0 then count := count + 1; end; writeln('Количество нечётных чисел: ', count); end. ```
2) Дан массив из 20 целых чисел. Все отрицательные элементы массива заменить на 0 и вывести полученный массив на экран.
```pascal program ReplaceNegatives; var arr: array[1..20] of integer; i: integer; begin for i := 1 to 20 do begin readln(arr[i]); if arr[i] < 0 then arr[i] := 0; end; writeln('Полученный массив:'); for i := 1 to 20 do write(arr[i], ' '); end. ```
Это две программы на языке Паскаль для выполнения задач. Первая программа находит количество нечётных чисел в массиве из 10 целых чисел, а вторая программа заменяет отрицательные элементы массива из 20 целых чисел на 0 и выводит полученный массив на экран.


Похожие вопросы


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili