Вопрос задан 14.06.2023 в 05:02.
Предмет Информатика.
Спрашивает Сергеев Георгий.
Дано произвольное число. Напишите программу, которая в случае, если число окажется положительным,
выведет квадратный корень из заданного числа. Если число равно 0, то выведет 0. А если число – отрицательное, то произойдет вывод заданного числа, умноженного на 2.Ответы на вопрос
Отвечает Лысогорский Александр.
Ответ:
Program NumberCheck;
var num:integer;
begin
readln(num);
if num > 0 then writeln(sqrt(num):0:2);
if num = 0 then writeln(0);
if num < 0 then writeln(num * 2);
end.
Объяснение:
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Python, которая выполняет указанные условия:
pythonimport math
number = float(input("Введите число: "))
if number > 0:
square_root = math.sqrt(number)
print("Квадратный корень из числа:", square_root)
elif number == 0:
print("Число равно 0")
else:
multiplied_number = number * 2
print("Умноженное на 2 число:", multiplied_number)
Программа запрашивает у пользователя ввод числа. Затем она проверяет условия: если число больше 0, то вычисляет квадратный корень и выводит его. Если число равно 0, то выводит 0. Иначе, если число отрицательное, умножает его на 2 и выводит результат.
Похожие вопросы
Информатика 78
Информатика 94
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
