Вопрос задан 14.06.2023 в 02:43. Предмет Информатика. Спрашивает Нехведович Анастасия.

Написать программу в phyton. 4. Найти все четырёхзначные числа, у которых сумма крайних цифр

равна сумме сред¬них (например, 3221). 5. Найти все двухзначные числа, которые при умножении на 2 заканчиваются на 8, а при умножении на 3 — на 4.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Койков Владислав.

Відповідь:

4. Найти все четырёхзначные числа, у которых сумма крайних цифр равна сумме сред¬них (например, 3221).

Python code:  

check = []

for i in range(1000,10000):

   check = list(map(int,str(i)))

   if((check[0] + check[3]) == (check[1] + check[2])):

       print(i)

5. Найти все двухзначные числа, которые при умножении на 2 заканчиваются на 8, а при умножении на 3 — на 4.  

Ну вообще таких чисел нет,но код все таки напишем

Python code:

for i in range(10,100):

 

   if ((i * 2) % 10 == 8) and ((i*3) % 10 == 4):

       print(i)

       

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот решения для обоих задач на языке Python:

Задача 4: Найти все четырёхзначные числа, у которых сумма крайних цифр равна сумме средних:

python
def find_numbers(): for number in range(1000, 10000): thousands = number // 1000 hundreds = (number // 100) % 10 tens = (number // 10) % 10 units = number % 10 if thousands + units == hundreds + tens: print(number) find_numbers()

Задача 5: Найти все двухзначные числа, которые при умножении на 2 заканчиваются на 8, а при умножении на 3 — на 4:

python
def find_numbers(): for number in range(10, 100): if (number * 2) % 10 == 8 and (number * 3) % 10 == 4: print(number) find_numbers()

Оба этих кода выводят результаты на экран. Если вы хотите сохранить результаты в переменные или файл, можно внести некоторые изменения в код.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос