Срочно 1.Напишите программу, вычисляющую площадь ромба. Пользователь с клавиатуры вводит длину
двух его диагоналей. 2.Пользователь вводит номер месяца, напишите программу, которая выводит пору года в зависимости от введенного месяца.Ответы на вопрос
Ответ:
1)print((int(input('d1')) * int(input('d2'))) / 2)
2)program znanija;
uses crt;
var x: integer;
begin
write ('введите номер месяца');
read (x);
if (x>=3) and (x<=5) then
write ('весна');
if (x>=6) and (x<8) then
write ('лето');
if (x>=9) and (x<=11) then
write ('осень');
if (x=12) or (x<=2) then
write ('зима');
end.
Объяснение:
Ответ: Как я поняла, раз ты проверял через питон - тебе нужно было на питоне. Если что-то непонятно или не устраивает ответ - пиши, чё-т придумаю.
Python Code:
1) ----------------------------------------
a = float(input('Диагональ a = '))
b = float(input('Диагональ b = '))
print(f'S = (a·b)/2 = {(a*b)/2}')
2) ----------------------------------------
print('Введите номер месяца.')
user_input = ui = int(input(': '))
if ui in [12,1,2]:
print('Это месяц зимы.')
elif 8 < ui < 12:
print('Это месяц осени.')
elif 5 < ui < 9:
print('Это месяц лета.')
elif 2 < ui < 6:
print('Это месяц весны.')
else:
print('Это месяц?')

Конечно! Вот две программы на языке Python, выполняющие задачи, которые вы описали:
- Программа для вычисления площади ромба:
pythondiagonal1 = float(input("Введите длину первой диагонали: "))
diagonal2 = float(input("Введите длину второй диагонали: "))
area = (diagonal1 * diagonal2) / 2
print("Площадь ромба равна:", area)
- Программа для определения поры года на основе введенного номера месяца:
pythonmonth = int(input("Введите номер месяца (от 1 до 12): "))
if month in [1, 2, 12]:
season = "Зима"
elif month in [3, 4, 5]:
season = "Весна"
elif month in [6, 7, 8]:
season = "Лето"
elif month in [9, 10, 11]:
season = "Осень"
else:
season = "Неверный номер месяца. Введите число от 1 до 12."
print("Пора года:", season)
Обе программы запрашивают ввод от пользователя и выводят результат в консоль.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
