Вопрос задан 11.06.2023 в 02:20.
Предмет Информатика.
Спрашивает Кадников Андрей.
Написать программу для вычисления количества элементов массива, отличных от нулю С++
Ответы на вопрос
Отвечает Куделина Катя.
#include <bits/stdc++.h>
using namespace std;
int main() {
int n;
cin >> n; // считываниe количества элементов массива
int ans = 0;
for (int i = 0, x; i < n; i++) {
cin >> x; // считывание элементов (всего будет считано n)
ans += x != 0;
}
cout << ans << '\n';
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на C++, которая вычисляет количество элементов массива, отличных от нуля:
cpp#include <iostream>
int countNonZeroElements(int arr[], int size) {
int count = 0;
for (int i = 0; i < size; i++) {
if (arr[i] != 0) {
count++;
}
}
return count;
}
int main() {
int arr[] = {1, 0, 3, 0, 5, 0, 7};
int size = sizeof(arr) / sizeof(arr[0]);
int nonZeroCount = countNonZeroElements(arr, size);
std::cout << "Number of non-zero elements: " << nonZeroCount << std::endl;
return 0;
}
Программа определяет функцию countNonZeroElements, которая принимает массив и его размер в качестве аргументов и возвращает количество элементов, отличных от нуля. В функции main создается массив arr с некоторыми значениями, и затем вызывается функция countNonZeroElements, чтобы получить количество ненулевых элементов. Результат выводится на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
