
Вопрос задан 10.06.2023 в 18:41.
Предмет Информатика.
Спрашивает Сапожников Дмитрий.
Написать программу на Java для вычисления факториала числа.


Ответы на вопрос

Отвечает Цыплакова Елизавета.
Ответ:
import java.util.Scanner;
public class Factorial {
public static void main(String[] args) {
Scanner input = new Scanner(System.in);
System.out.print("Введите целое число для вычисления факториала: ");
int number = input.nextInt();
long factorial = 1;
for (int i = 1; i <= number; i++) {
factorial *= i;
}
System.out.println(number + "! = " + factorial);
}
}



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на Java для вычисления факториала числа:
javaimport java.util.Scanner;
public class FactorialCalculator {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
System.out.print("Введите число: ");
int number = scanner.nextInt();
scanner.close();
long factorial = calculateFactorial(number);
System.out.println("Факториал числа " + number + " равен " + factorial);
}
public static long calculateFactorial(int number) {
if (number < 0) {
throw new IllegalArgumentException("Число не может быть отрицательным");
}
long factorial = 1;
for (int i = 1; i <= number; i++) {
factorial *= i;
}
return factorial;
}
}
Программа запрашивает у пользователя число, для которого нужно вычислить факториал. Затем она вызывает метод calculateFactorial
, который вычисляет факториал числа и возвращает результат. Результат выводится на экран.


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili