Вопрос задан 07.06.2023 в 22:28. Предмет Информатика. Спрашивает Ясюченя Арсений.

Составить программу,котороая вычисляет сумму n вводимых с клавиатуры чисел,выбирая из них только

двузначные четные положительные числа(с циклом for и while) Помогите пожалуйста,даю 100 баллов за ответ​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Амзенова Карина.

#Вариант с циклом for

total = 0

for i in range(int(input('n = '))):

   tm = int(input())

   if 9 < tm < 100:

       total += tm    #тоже самое что и: total = total + tm

print(f'{total=}')

#Вариант с циклом while

total = 0

n = int(input('n = '))

while n > 0:

   tm = int(input())

   if 9 < tm < 100:

       total += tm

print(total)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам с этим. Вот две программы, использующие цикл for и цикл while для вычисления суммы двузначных четных положительных чисел, вводимых с клавиатуры:

Программа с использованием цикла for:

python
sum_numbers = 0 n = int(input("Введите количество чисел: ")) for _ in range(n): number = int(input("Введите число: ")) if 10 <= number < 100 and number % 2 == 0: sum_numbers += number print("Сумма двузначных четных чисел:", sum_numbers)

Программа с использованием цикла while:

python
sum_numbers = 0 n = int(input("Введите количество чисел: ")) count = 0 while count < n: number = int(input("Введите число: ")) if 10 <= number < 100 and number % 2 == 0: sum_numbers += number count += 1 print("Сумма двузначных четных чисел:", sum_numbers)

Обе программы сначала запрашивают количество чисел n, которые вы хотите ввести. Затем они просит вас ввести числа по одному и проверяет, являются ли они двузначными четными числами. Если число удовлетворяет условию, оно добавляется к переменной sum_numbers. В конце программы выводится сумма двузначных четных чисел.

Надеюсь, это поможет! Если у вас возникнут еще вопросы, пожалуйста, не стесняйтесь задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос