Вопрос задан 06.06.2023 в 08:51.
Предмет Информатика.
Спрашивает Базарбай Айдос.
1. Напишите программу для вычисления выражения y=4x-9, где х целое число, вводимое с клавиатуры.
Вывод оформите следующим образом: при X= ... Y=...2. Напишите программу для вычисления значения выражения у= √х-2х(все под корнем) где к целое х число, вводимое с клавиатуры. Вывод оформите в виде x=... Y=...ПаскальОтветы на вопрос
Отвечает Чичканова Вероника.
1.
program Expression1;
var x, y: integer;
begin
writeln('Введите значение x: ');
readln(x);
y := 4 * x - 9;
writeln('При x = ', x, ' y = ', y);
end.
2.
program Expression2;
var x, y: integer;
begin
writeln('Введите значение x: ');
readln(x);
y := round(sqrt(x - 2 * x));
writeln('При x = ', x, ' y = ', y);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Паскаль, которая решает задачу:
pascalprogram ExpressionCalculation; var x, y: Integer; begin // Ввод значения x с клавиатуры Write('Введите значение x: '); ReadLn(x); // Вычисление выражения y = 4x - 9 y := 4 * x - 9; // Вывод результата WriteLn('При x = ', x, ', y = ', y); // Вычисление выражения y = sqrt(x) - 2 * x y := Round(Sqrt(x) - 2 * x); // Вывод результата WriteLn('При x = ', x, ', y = ', y); end.
Пожалуйста, обратите внимание, что этот пример кода написан на языке Паскаль.
Топ вопросов за вчера в категории Информатика
Информатика 20
Информатика 23
Информатика 21
Информатика 29
Информатика 21
Информатика 20
Информатика 26
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
