Вопрос задан 05.06.2023 в 00:17. Предмет Информатика. Спрашивает Турович Сергей.

ПИТОН. Напишите программу, которая в символьной строке заменяет все нули на единицы и наоборот.

Остальные символы не должны измениться. Например:Ввод:101501Вывод: 010510*Решите сами, я уже видел многонепонятных ответов​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Соловьёв Андрей.

my_string = input()

result = str()

for i in my_string:

   if i == '0':

       result += '1'

   elif i == '1':

       result += '0'

   else:

       result += i

print(result)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке Python, которая заменяет нули на единицы и наоборот в символьной строке:

python
def reverse_zeros_ones(input_string): output_string = "" for char in input_string: if char == '0': output_string += '1' elif char == '1': output_string += '0' else: output_string += char return output_string # Пример использования input_string = input("Введите символьную строку: ") result = reverse_zeros_ones(input_string) print("Вывод:", result)

Вы можете запустить эту программу, ввести символьную строку и увидеть результат замены нулей на единицы и наоборот. Например, если введенная строка будет "101501", программа выведет "010510".

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос