Вопрос задан 04.06.2023 в 06:58. Предмет Информатика. Спрашивает Быков Виктор.

Количество пятерок На вход программе подается последовательность целых чисел от 1 до 5,

характеризующее оценку ученика, каждое число на отдельной строке. Концом последовательности является любое отрицательное число, либо число большее 5. Напишите программу, которая выводит количество пятерок. ПОМОГИТЕ ПРОШУ
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Гребенщикова Влада.

Python:

mark = int(input())

count = 0

if mark == 5:

       count += 1

while (mark<=5 and mark>0):

   mark = int(input())

   if mark == 5:

       count += 1

print(count)

Ввод/Вывод:

1                                                                                                                                

1                                                                                                                                

5                                                                                                                                

5                                                                                                                                

5                                                                                                                                

5                                                                                                                                

5                                                                                                                                

-1                                                                                                                              

5    

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам с написанием программы на Python, которая будет считать количество пятерок в последовательности оценок. Вот пример решения:

python
count = 0 # переменная для подсчета пятерок while True: grade = int(input()) # считываем очередную оценку if grade == 5: count += 1 if grade < 0 or grade > 5: # проверяем условие окончания последовательности break print("Количество пятерок:", count)

Эта программа считывает целые числа, представляющие оценки ученика, по одной на каждой строке. Она продолжает считывать оценки до тех пор, пока не встретит отрицательное число или число большее 5. При каждом считывании, если оценка равна 5, переменная count увеличивается на 1. После окончания считывания, программа выводит количество пятерок.

Вы можете запустить этот код в своей среде разработки или интерпретаторе Python и вводить оценки по одной на каждой строке. Программа остановится и выведет количество пятерок, когда вы введете отрицательное число или число большее 5.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос