Вопрос задан 20.06.2018 в 03:15.
Предмет Информатика.
Спрашивает Кошкин Лев.
НАДО РЕШИТЬ ДВУМЕРНЫМ МАССИВОМ! Даны два числа n и m. Создайте двумерный массив A[n][m], заполните
его таблицей умножения A[i][j]=i*j и выведите на экран. При этом нельзя использовать вложенные циклы, все заполнение массива должно производиться одним циклом.Входные данныеПрограмма получает на вход два числа n и m – количество строк и столбцов, соответственно.Выходные данныеПрограмма должна вывести полученный массив. Числа разделяйте одним пробелом.Примерывходные данные3 3 выходные данные0 0 0 0 1 2 0 2 4Ответы на вопрос
Отвечает Нурканова Диляра.
Var
A:array[0..100,0..100] of integer;
i,N,M:integer;
Begin
ReadLn(N,M);
For i:= 0 to N*M-1 do
Begin
A[i div N, i mod M]:=(i div N)*(i mod M);
Write(A[i div N, i mod M],' ')
End
End.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
