 
Вопрос задан 04.05.2021 в 18:32.
Предмет Информатика.
Спрашивает Панова Софья.
Напишите программу пожалуйста В последовательности натуральных чисел определить сумму чисел
кратных 5 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Ли Юлия.
                
                   Будем считать последовательность натуральных чисел такую:              
1,2,3,4 .. n-1,n
Тогда программа может быть такой:
              
var
i, s, n: integer;
              
begin
write('Введите число натуральных чисел: ');
readln(n);
for i := 1 to n do
if i mod 5 = 0 then s := s + i;
writeln('Сумма кратных 5 = ', s);
end.
              
              
                                        1,2,3,4 .. n-1,n
Тогда программа может быть такой:
var
i, s, n: integer;
begin
write('Введите число натуральных чисел: ');
readln(n);
for i := 1 to n do
if i mod 5 = 0 then s := s + i;
writeln('Сумма кратных 5 = ', s);
end.
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Конечно, вот простой пример программы на языке Python:
python# Запрашиваем у пользователя длину последовательности
n = int(input("Введите длину последовательности: "))
# Инициализируем переменную для хранения суммы чисел, кратных 5
sum = 0
# Цикл от 1 до n включительно
for i in range(1, n+1):
    # Проверяем, кратно ли число 5
    if i % 5 == 0:
        # Если кратно, добавляем его к сумме
        sum += i
# Выводим результат
print("Сумма чисел, кратных 5: ", sum)
Программа запрашивает у пользователя длину последовательности и затем проходит по всем числам от 1 до n, проверяя, кратно ли число 5. Если число кратно 5, оно добавляется к переменной sum, которая и хранит сумму всех чисел, кратных 5. В конце программы выводится результат.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			