
Вопрос задан 01.05.2021 в 22:00.
Предмет Информатика.
Спрашивает Гарбузов Роман.
Напишите программу для турбо паскаля. Условие: фирма осуществляет набор сотрудников, условия приёма
: требуется не менее 3 лет рабочего стажа и возраст не более 35 лет.

Ответы на вопрос

Отвечает Джиндарян Олег.
Var
vozrast,stash:integer;
writeln('Сколько вам лет');
readln(vozrast);
writeln('Какой у вас рабочий стаж');
readln(stash);
if (vozrast< 35) and (stash>3) then
writeln('Мы берем вас на работу')
else writeln('Вы нам не подходите');
end.
vozrast,stash:integer;
writeln('Сколько вам лет');
readln(vozrast);
writeln('Какой у вас рабочий стаж');
readln(stash);
if (vozrast< 35) and (stash>3) then
writeln('Мы берем вас на работу')
else writeln('Вы нам не подходите');
end.



Отвечает Поляков Иван.
Var a,b,c:real;
begin
writeln ('Введите Ваш рабочий стаж:');
readln (a);
writeln ('Введите Ваш возраст:');
readln (b);
if (a>=3) and (b<=35) then
writeln ('Вы нам подходите') else
writeln ('К сожалению, Вы нам не подходите');
end.
begin
writeln ('Введите Ваш рабочий стаж:');
readln (a);
writeln ('Введите Ваш возраст:');
readln (b);
if (a>=3) and (b<=35) then
writeln ('Вы нам подходите') else
writeln ('К сожалению, Вы нам не подходите');
end.



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Привет! Вот пример программы на Turbo Pascal, которая запрашивает у пользователя данные о сотрудниках и проверяет, соответствуют ли они условиям приема:
luaprogram hiring;
type
Employee = record
name: string;
age: integer;
experience: integer;
end;
var
newEmployee: Employee;
begin
writeln('Введите данные о новом сотруднике:');
write('Имя: ');
readln(newEmployee.name);
write('Возраст: ');
readln(newEmployee.age);
write('Опыт работы (в годах): ');
readln(newEmployee.experience);
if (newEmployee.age <= 35) and (newEmployee.experience >= 3) then
writeln('Сотрудник ', newEmployee.name, ' принят на работу.')
else
writeln('К сожалению, сотрудник ', newEmployee.name, ' не соответствует условиям приема.');
readln; // Ждем, пока пользователь нажмет Enter, чтобы закрыть программу
end.
Программа запрашивает у пользователя данные о новом сотруднике: имя, возраст и опыт работы (в годах). Затем она проверяет, соответствует ли этот сотрудник условиям приема: возраст не более 35 лет и опыт работы не менее 3 лет. Если да, то программа выводит сообщение о том, что сотрудник принят на работу, иначе программа сообщает о том, что сотрудник не соответствует условиям приема.


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili