Вопрос задан 27.04.2021 в 19:16.
Предмет Информатика.
Спрашивает Голота Валера.
Написать программу(pascal) для решения задачи, Вводится последовательность чисел, кратных 3.
Найти номера двух соседних чисел из данного набора, произведение которых является минимальным.Ответы на вопрос
Отвечает Назаров Олег.
var
a,n,min:integer;
begin
readln(a);
n:=1;
min:=100;
if (a mod 3 <>0) or (a=0) then
begin
writeln('Net par');
exit;
end
else
begin
n:=a;
repeat
readln(a);
if a mod 3 <> 0 then break;
n:=n*a;
if (n<min) then min:=n;
n:=a;
until (a mod 3 <> 0) or (a=0);
end;
writeln;
if min = 100 then writeln('Net par') else
writeln(Min);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Привет! Вот решение на языке Pascal:
lessprogram FindMinProduct;
var
input: array[1..100] of integer; // Массив для хранения последовательности чисел
n, i, minProd, minIndex: integer;
begin
// Вводим последовательность чисел, пока не встретим -1
n := 0;
repeat
n := n + 1;
readln(input[n]);
until (input[n] mod 3 = 0) and (input[n] <> -1);
// Находим номера двух соседних чисел, произведение которых минимально
minProd := input[1] * input[2];
minIndex := 1;
for i := 2 to n-1 do
begin
if input[i] * input[i+1] < minProd then
begin
minProd := input[i] * input[i+1];
minIndex := i;
end;
end;
// Выводим результаты
writeln('Номера чисел: ', minIndex, ' и ', minIndex+1);
writeln('Произведение: ', minProd);
end.
Программа считывает последовательность чисел, кратных 3, пока не встретит число -1. Затем она проходит по всей последовательности и находит номера двух соседних чисел, произведение которых минимально. Результаты выводятся на экран.
Надеюсь, это поможет!
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 25
Информатика 33
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
