Вопрос задан 26.04.2021 в 08:33.
Предмет Информатика.
Спрашивает Свиридов Влад.
Нужно написать линейную программу перевода четырехзначного двоичного числа в десятичную систему
счисления.Ответы на вопрос
Отвечает Искалиева Алина.
Var s : String;
Begin
Repeat
Readln(s);
Until Length(s)=4;
Writeln((Ord(s[1])-Ord('0'))*8+(Ord(s[2])-Ord('0'))*4+(Ord(s[3])-Ord('0'))*2+(Ord(s[4])-Ord('0')));
end.
Begin
Repeat
Readln(s);
Until Length(s)=4;
Writeln((Ord(s[1])-Ord('0'))*8+(Ord(s[2])-Ord('0'))*4+(Ord(s[3])-Ord('0'))*2+(Ord(s[4])-Ord('0')));
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для перевода четырехзначного двоичного числа в десятичную систему счисления можно использовать следующую линейную программу:
sql// Входные данные - четырехзначное двоичное число (строка из 0 и 1)
input binary
// Инициализируем переменную для хранения результата
var result = 0
// Вычисляем значение для каждого разряда, начиная с младшего
result += binary[3] * 1
result += binary[2] * 2
result += binary[1] * 4
result += binary[0] * 8
// Выводим результат
output result
Для работы программы нужно передать на вход четырехзначное двоичное число в виде строки из символов '0' и '1'. Результат будет выведен на экран в виде десятичного числа.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
