Вопрос задан 18.04.2021 в 17:00.
Предмет Информатика.
Спрашивает Заграйчук Денис.
Напишите программу в с++ с помощью switch: Пользователь вводит число.Определить, является ли оно
четным.Ответы на вопрос
Отвечает Митюрева Анастасия.
#include <iostream>
using namespace std;
int main(){
int a;
cin>>a;
switch (a%2){
case 0:
{
cout<<"Yes";
break;
}
default:
cout<<"No";
}
cin.get();
cin.get();
return 0;
}
using namespace std;
int main(){
int a;
cin>>a;
switch (a%2){
case 0:
{
cout<<"Yes";
break;
}
default:
cout<<"No";
}
cin.get();
cin.get();
return 0;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на C++, которая использует оператор switch, чтобы определить, является ли введенное пользователем число четным или нет:
c++#include <iostream>
using namespace std;
int main() {
int num;
cout << "Введите целое число: ";
cin >> num;
switch (num % 2) {
case 0:
cout << num << " является четным." << endl;
break;
case 1:
cout << num << " является нечетным." << endl;
break;
}
return 0;
}
Когда пользователь вводит число, мы используем оператор % для нахождения остатка от деления числа на 2. Если остаток равен 0, то число четное, и программа выводит сообщение "num является четным." Если остаток равен 1, то число нечетное, и программа выводит сообщение "num является нечетным." В конце программы мы возвращаем 0, чтобы указать, что программа завершилась без ошибок.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
