Вопрос задан 17.04.2021 в 12:07.
Предмет Информатика.
Спрашивает Волокушкин Святослав.
С++.Составить программу диалог-визитка из 5 вопросов. Помогите.
Ответы на вопрос
Отвечает Максут Мухамед.
#include <iostream>
int main(){
bool a = 0; //какая-то переменная для обработки ответов
cout<<"Тут первый вопрос"<<endl;
cin>>a;
if(a){ //тут собственно обработка положительного ответа}
else //а тут отрицательного
a=0; //обнуление переменной
//и так 5 раз
return 0;
}
int main(){
bool a = 0; //какая-то переменная для обработки ответов
cout<<"Тут первый вопрос"<<endl;
cin>>a;
if(a){ //тут собственно обработка положительного ответа}
else //а тут отрицательного
a=0; //обнуление переменной
//и так 5 раз
return 0;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь вам с написанием программы диалог-визитки на C++! Ниже приведен пример кода, который задает пользователю пять вопросов и выводит их ответы в консоли:
cpp#include <iostream>
#include <string>
using namespace std;
int main() {
string name, job_title, company, email, phone_number;
cout << "What is your name? ";
getline(cin, name);
cout << "What is your job title? ";
getline(cin, job_title);
cout << "What company do you work for? ";
getline(cin, company);
cout << "What is your email address? ";
getline(cin, email);
cout << "What is your phone number? ";
getline(cin, phone_number);
cout << endl;
cout << "Name: " << name << endl;
cout << "Job Title: " << job_title << endl;
cout << "Company: " << company << endl;
cout << "Email: " << email << endl;
cout << "Phone Number: " << phone_number << endl;
return 0;
}
Как вы можете видеть, мы создали пять переменных типа string, каждая из которых будет хранить ответ пользователя на соответствующий вопрос. Затем мы выводим вопросы в консоли и запрашиваем ответы пользователя с помощью функции getline(). Наконец, мы выводим ответы в консоли, используя операторы вывода <<.
Надеюсь, этот код поможет вам начать работу! Если у вас есть какие-либо вопросы, пожалуйста, не стесняйтесь спрашивать!
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
