Вопрос задан 16.04.2021 в 00:06.
Предмет Информатика.
Спрашивает Курченков Владислав.
3. Написать программу на языке JAVA, которая по заданному номеру единицы измерения (1 – килограмм,
2 – миллиграмм, 3 – грамм, 4 – тонна, 5 – центнер) и массы M выдавала бы соответствующее значение массы в килограммах.помогите пожалуйстааОтветы на вопрос
Отвечает Иващенко Андрей.
Import java.util.*;
public class zadacha
{
public static void main(String[]args)
{
cout("Введите номер ед.изм: ");
@SuppressWarnings("resource") Scanner cin = new Scanner (System.in);
double v=cin.nextInt();
cout("Введите массу в указанной ед.изм: ");
double m=cin.nextDouble();
if (v==1) {
print(m);
}
else if (v==2) {
print(m/st(6));
}
else if (v==3) {
print(m/st(3));
}
else if (v==4) {
print(m*st(3));
}
else if (v==5) {
print(m*st(2));
}
}
public static void cout (String text)
{
System.out.print(text);
}
public static void print(double printer)
{
System.out.print(printer);
}
public static int st(int t)
{
t=(int) Math.pow(10, t); return t;
}
}
public class zadacha
{
public static void main(String[]args)
{
cout("Введите номер ед.изм: ");
@SuppressWarnings("resource") Scanner cin = new Scanner (System.in);
double v=cin.nextInt();
cout("Введите массу в указанной ед.изм: ");
double m=cin.nextDouble();
if (v==1) {
print(m);
}
else if (v==2) {
print(m/st(6));
}
else if (v==3) {
print(m/st(3));
}
else if (v==4) {
print(m*st(3));
}
else if (v==5) {
print(m*st(2));
}
}
public static void cout (String text)
{
System.out.print(text);
}
public static void print(double printer)
{
System.out.print(printer);
}
public static int st(int t)
{
t=(int) Math.pow(10, t); return t;
}
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь в написании программы на языке Java, которая будет принимать входные данные в виде номера единицы измерения и массы и выводить соответствующее значение массы в килограммах.
Вот пример кода для этой программы:
javaimport java.util.Scanner;
public class WeightConverter {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
// Запросить у пользователя номер единицы измерения и массу
System.out.print("Введите номер единицы измерения (1-килограмм, 2-миллиграмм, 3-грамм, 4-тонна, 5-центнер): ");
int unit = scanner.nextInt();
System.out.print("Введите массу: ");
double weight = scanner.nextDouble();
// Вычислить и вывести соответствующее значение массы в килограммах
switch (unit) {
case 1:
System.out.println("Масса в килограммах: " + weight);
break;
case 2:
System.out.println("Масса в килограммах: " + weight / 1000000);
break;
case 3:
System.out.println("Масса в килограммах: " + weight / 1000);
break;
case 4:
System.out.println("Масса в килограммах: " + weight * 1000);
break;
case 5:
System.out.println("Масса в килограммах: " + weight * 100);
break;
default:
System.out.println("Неправильный номер единицы измерения.");
}
scanner.close();
}
}
Эта программа запрашивает у пользователя номер единицы измерения и массу, а затем использует оператор switch для вычисления и вывода соответствующего значения массы в килограммах. Номер единицы измерения может быть 1, 2, 3, 4 или 5, соответственно килограмм, миллиграмм, грамм, тонна и центнер. Если пользователь вводит неправильный номер единицы измерения, программа выводит сообщение об ошибке.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 33
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
