Написать программу нахождения наименьшего элемента двумерного массива размером 2*5. Элементы
массива вводит пользователь. паскальОтветы на вопрос
с++;
#include <bits/stdc++.h>
using namespace std;
int main(){
int a[2][5],min;
for(int i=0;i<2;i++){
for(int j=0;j<5;j++){
cin>>a[i][j];
}
min=a[0][0];
}
for(int i=0;i<2;i++){
for(int j=0;j<5;j++){
if(a[i][j]<min){
min=a[i][j];
}
}
}
cout<<min;
}
Вот пример программы на языке Pascal, который находит наименьший элемент в двумерном массиве размером 2*5, введенном пользователем:
arduinoprogram MinElement;
var
arr: array[1..2,1..5] of Integer;
i, j, min: Integer;
begin
// Заполнение массива данными, введенными пользователем
writeln('Введите элементы массива:');
for i := 1 to 2 do
begin
for j := 1 to 5 do
begin
write('arr[', i, '][', j, ']: ');
readln(arr[i][j]);
end;
end;
// Нахождение наименьшего элемента в массиве
min := arr[1][1];
for i := 1 to 2 do
begin
for j := 1 to 5 do
begin
if arr[i][j] < min then
begin
min := arr[i][j];
end;
end;
end;
writeln('Наименьший элемент в массиве: ', min);
readln;
end.
В этой программе мы сначала заполняем массив arr данными, введенными пользователем, а затем ищем наименьший элемент в массиве с помощью двойного цикла for. Мы начинаем сравнивать каждый элемент массива со значением min, которое изначально равно arr[1][1]. Если находим элемент, который меньше min, мы обновляем значение min. В конце программы мы выводим значение min, которое является наименьшим элементом в массиве.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
