Вопрос задан 12.04.2021 в 20:45.
Предмет Информатика.
Спрашивает Рей Эвелина.
Составить программу для вычисления над 2 числами, введеными с клавиатуры. Если ввели > и значит
делим числа, если знак <*>, то перемножаем.Результат выводим на экран. Использовать оператор Case.Ответы на вопрос
Отвечает Смирнов Максим.
-------------------------------------

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Код на языке C++ для вычисления действий над 2 числами в зависимости от введенного знака операции:
cpp#include <iostream>
using namespace std;
int main() {
char op;
double num1, num2, result;
cout << "Введите два числа: ";
cin >> num1 >> num2;
cout << "Введите знак операции (+, -, *, /): ";
cin >> op;
switch(op) {
case '+':
result = num1 + num2;
break;
case '-':
result = num1 - num2;
break;
case '*':
result = num1 * num2;
break;
case '/':
result = num1 / num2;
break;
default:
cout << "Неверный знак операции!";
return 0;
}
cout << "Результат: " << result;
return 0;
}
В данном коде используется оператор switch для выбора нужного действия в зависимости от введенного знака операции. В данном случае, допустимыми знаками являются: +, -, * и /. Если введен неверный знак операции, программа выводит сообщение об ошибке и завершается.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
