
Помогите пожалуйста с ПРОГРАМИРИВАНИЕМ в паскале с оператором If. Даны три целых числа A, B, C.
Определить, есть ли среди них хотя бы одно четное и хотя бы одно нечетное.Входные данныеЧисла A, B, C, не превышающие по модулю 10000.Выходные данныеОдна строка – "YES" или "NO".и 2Дано три числа, записанный в отдельных строках. Упорядочите их в порядке неубывания. Программа должна считывать три числа a, b, c, затем программа должна менять их значения так, чтобы стали выполнены условия a <= b <= c, затем программа выводит тройку a, b, c.Входные данныеВводятся три числа, каждое записано в отдельной строке.Выходные данныеВыведите ответ на задачу.

Ответы на вопрос

Ответ:
Задание 1
a = int(input())
b = int(input())
c = int(input())
if (a % 2 == 0 and b % 2 != 0) or (a % 2 != 0 and b % 2 == 0):
print("YES")
elif (a % 2 == 0 and c % 2 != 0) or (a % 2 != 0 and c % 2 == 0):
print("YES")
elif (b % 2 == 0 and c % 2 != 0) or (b % 2 != 0 and c % 2 == 0):
print("YES")
else:
print("NO")
Задание 2
Var i,j,t:integer;
a:array[1..3] of integer;
Begin
for i:=1 to 3 do
readln(a[i]);
for i:=1 to 3 do
for j:=i+1 to 3 do
if a[i]>=a[j] then
begin
t:=a[i];
a[i]:=a[j];
a[j]:=t;
end;
for i:=1 to 3 do
write(a[i],' ');
End.
Объяснение:



Конечно! Вот решение задачи на языке Pascal:
- Проверка наличия хотя бы одного четного и хотя бы одного нечетного числа:
pascalprogram CheckEvenOdd; var A, B, C: Integer; begin // Ввод чисел Readln(A, B, C); // Проверка условия if ((A mod 2 = 0) and (B mod 2 <> 0) and (C mod 2 <> 0)) or ((A mod 2 <> 0) and (B mod 2 = 0) and (C mod 2 <> 0)) or ((A mod 2 <> 0) and (B mod 2 <> 0) and (C mod 2 = 0)) then Writeln('YES') else Writeln('NO'); end.
- Упорядочивание трех чисел в порядке неубывания:
pascalprogram SortNumbers; var A, B, C, Temp: Integer; begin // Ввод чисел Readln(A, B, C); // Упорядочивание чисел if A > B then begin Temp := A; A := B; B := Temp; end; if B > C then begin Temp := B; B := C; C := Temp; end; if A > B then begin Temp := A; A := B; B := Temp; end; // Вывод чисел Writeln(A, ' ', B, ' ', C); end.
Надеюсь, это поможет вам решить задачи по программированию на языке Pascal. Если у вас возникнут еще вопросы, не стесняйтесь задавать их!


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili