Вопрос задан 07.04.2021 в 15:24.
Предмет Информатика.
Спрашивает Омельницкая Софья.
на вход программе подается количество битов.составьте программу ,которая переводит биты в байты
,килобайты,мегабайты,гигабайты.Заранее спасибо!)Ответы на вопрос
Отвечает Курманова Виталина.
Program bity;
var a, b, c, d, e: real;
begin
write ('Введите количество бит: ');
read (a);
b:=a/8;
c:=b/1024;
d:=c/1024;
e:=d/1024;
writeln ('Это столько байт: ', b:8:4);
writeln ('Это столько килобайт: ', c:8:4);
writeln ('Это столько мегабайт: ', d:8:4);
write ('Это столько гигабайт: ', e:8:4);
end.
var a, b, c, d, e: real;
begin
write ('Введите количество бит: ');
read (a);
b:=a/8;
c:=b/1024;
d:=c/1024;
e:=d/1024;
writeln ('Это столько байт: ', b:8:4);
writeln ('Это столько килобайт: ', c:8:4);
writeln ('Это столько мегабайт: ', d:8:4);
write ('Это столько гигабайт: ', e:8:4);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конвертация битов в байты, килобайты, мегабайты и гигабайты может быть произведена следующим образом:
pythonbits = int(input("Введите количество битов: "))
bytes = bits / 8
kilobytes = bytes / 1024
megabytes = kilobytes / 1024
gigabytes = megabytes / 1024
print(f"Байтов: {bytes}")
print(f"Килобайтов: {kilobytes}")
print(f"Мегабайтов: {megabytes}")
print(f"Гигабайтов: {gigabytes}")
Программа запрашивает количество битов, затем производит конвертацию и выводит результаты. Важно отметить, что при конвертации в килобайты, мегабайты и гигабайты используются степени двойки, поэтому коэффициентом конвертации является 1024, а не 1000.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 33
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
