Вопрос задан 04.04.2021 в 11:00.
Предмет Информатика.
Спрашивает Петрушова Лера.
Составить программу на паскаль: Рассчитать радиус окружности, вписанной в треугольник R1= S/p и
описанной вокруг треугольника R2= a*b*c/(4*S), где S - площадь, а p - полупериметр треугольника. a, b, c - стороны треугольника ( исходные данные ).Ответы на вопрос
Отвечает Сенина Карина.
Находим периметр p=a+b+c, затем полупериметр
, и далее по формуле Герона площадь S.
var
a,b,c,p,s,p2,r1,r2:real;
begin
Write('Введите стороны треугольника: ');
Read(a,b,c);
p:=a+b+c; p2:=p/2;
s:=sqrt(p2*(p2-a)*(p2-b)*(p2-c));
r1:=s/p; r2:=a*b*c/(4*s);
Writeln('R1=',r1,', R2=',r2)
end.
Тестовое решение:
Введите стороны треугольника: 4 6 7
R1=0.704502327470793, R2=3.50685603007684
var
a,b,c,p,s,p2,r1,r2:real;
begin
Write('Введите стороны треугольника: ');
Read(a,b,c);
p:=a+b+c; p2:=p/2;
s:=sqrt(p2*(p2-a)*(p2-b)*(p2-c));
r1:=s/p; r2:=a*b*c/(4*s);
Writeln('R1=',r1,', R2=',r2)
end.
Тестовое решение:
Введите стороны треугольника: 4 6 7
R1=0.704502327470793, R2=3.50685603007684
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Паскаль для расчета радиуса вписанной и описанной окружностей треугольника:
pascalprogram CalculateRadii; var a, b, c, S, p, R1, R2: real; begin writeln('Введите стороны треугольника:'); readln(a, b, c); p := (a + b + c) / 2; // Рассчитываем полупериметр треугольника // Рассчитываем площадь треугольника по формуле Герона S := sqrt(p * (p - a) * (p - b) * (p - c)); // Рассчитываем радиус вписанной окружности R1 := S / p; // Рассчитываем радиус описанной окружности R2 := (a * b * c) / (4 * S); writeln('Радиус вписанной окружности: ', R1); writeln('Радиус описанной окружности: ', R2); readln; end.
В этой программе пользователь должен ввести стороны треугольника a, b и c. Затем программа рассчитывает полупериметр p и площадь S треугольника. Далее вычисляются радиусы вписанной R1 и описанной R2 окружностей согласно указанным формулам.
Программа выводит значения радиусов вписанной и описанной окружностей на экран.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 25
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
