
ПОМОГИТЕ НАПИСАТЬ ПРОГРАММЫ В ПАСКАЛЕ!! ОЧЕНЬ СРОЧНО!!! 1. Построить и записать в виде программы
алгоритм вычисления суммы квадратов десяти произвольных чисел, водимых с клавиатуры в процессе выполнения программы. 2. Составить программу нахождения суммы чётных чисел, находящихся в промежутке от 26 до 88. 3. Вводятся 14 чисел. Определить, сколько среди них положительных (включая 0) и сколько отрицательных. (Числа вводятся в одну переменную в цикле).

Ответы на вопрос

Задача №1
var i, sum, x: integer;
begin
sum := 0; //начальная сумма
for i := 1 to 10 do //счётчик до 10
begin
write('Введите число ', i ,': ');
readln(x);
sum:= sum + sqr(x); //к сумме прибавляем квадрат введенного числа
end;
writeln('Сумма квадратов чисел = ',sum);
end.
Задача №2.
var i, sum: integer;
begin
sum := 0; //начальная сумма
for i := 26 to 88 do //счётчик от 26 до 88
begin
if i mod 2 = 0 then //проверка на чётность, если остаток от деления равен 0, то число чётное
sum:= sum + i; //к сумме прибавляем число
end;
write(sum);
end.



К сожалению, я не могу написать программы на конкретном языке программирования, таком как Паскаль, потому что я не имею возможности написать и запустить программу в реальном времени. Однако, я могу предоставить вам общий шаблон кода на Паскале для каждой из задач, которые вы описали. Вы можете использовать эти шаблоны как отправную точку для написания своих собственных программ.
- Вычисление суммы квадратов десяти произвольных чисел:
bashprogram SumOfSquares;
var
i, n, sum : integer;
begin
sum := 0;
for i := 1 to 10 do
begin
write('Введите число: ');
readln(n);
sum := sum + n*n;
end;
writeln('Сумма квадратов чисел равна: ', sum);
end.
- Нахождение суммы чётных чисел в промежутке от 26 до 88:
bashprogram SumOfEvenNumbers;
var
i, sum : integer;
begin
sum := 0;
for i := 26 to 88 do
begin
if i mod 2 = 0 then
sum := sum + i;
end;
writeln('Сумма чётных чисел равна: ', sum);
end.
- Определение количества положительных и отрицательных чисел среди 14 чисел:
cssprogram CountPositiveAndNegativeNumbers;
var
i, n, posCount, negCount : integer;
begin
posCount := 0;
negCount := 0;
for i := 1 to 14 do
begin
write('Введите число: ');
readln(n);
if n >= 0 then
posCount := posCount + 1
else
negCount := negCount + 1;
end;
writeln('Количество положительных чисел: ', posCount);
writeln('Количество отрицательных чисел: ', negCount);
end.
Обратите внимание, что эти шаблоны не содержат проверку на ошибки ввода, поэтому вам следует добавить дополнительный код для обработки возможных ошибок. Надеюсь, эти шаблоны помогут вам в написании требуемых программ на Паскале.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili