В классе 15 учеников. Составьте программу, которая определяет количество учеников, чей вес не
превышает среднего. Вес должен задаваться случайными числами в диапазоне от 35 до 60. Напишите программу в текстовом документе, либо в программе Pascal ABC и прикрепите файл.Ответы на вопрос
Ответ:
program num;
Var a:array [1..40] of integer;
j, s, k, n :integer;
sr:real;
begin
writeln('Введите количество учеников в классе');
readln(n);
writeln('Введите рост учеников');
for j:=1 to n do
begin
readln(a[j]);
end;
s:=0;
for j:=1 to n do
s:=s+a[j];
sr:=s/n;
k:=0;
for j:=1 to n do
if a[j]> sr then k:=k+1 ;
writeln('Количество учеников в классе, чей рост превышает средний= ', k);
end.
Объяснение:
Привет! Вот пример программы на Pascal ABC, которая определяет количество учеников, чей вес не превышает среднего:
pascalprogram WeightAverage; const MinWeight = 35; MaxWeight = 60; NumStudents = 15; var weights: array[1..NumStudents] of Integer; totalWeight, averageWeight: Real; i, count: Integer; begin // Инициализация генератора случайных чисел Randomize; // Генерация случайных весов для учеников totalWeight := 0; for i := 1 to NumStudents do begin weights[i] := Random(MaxWeight - MinWeight + 1) + MinWeight; totalWeight := totalWeight + weights[i]; end; // Расчёт среднего веса averageWeight := totalWeight / NumStudents; // Подсчёт количества учеников, чей вес не превышает среднего count := 0; for i := 1 to NumStudents do begin if weights[i] <= averageWeight then count := count + 1; end; // Вывод результатов writeln('Веса учеников:'); for i := 1 to NumStudents do begin writeln('Ученик ', i, ': ', weights[i]); end; writeln('Средний вес: ', averageWeight:0:2); writeln('Количество учеников, чей вес не превышает среднего: ', count); end.
Вы можете скопировать этот код и сохранить его в файле с расширением ".pas". Затем вы можете открыть его в Pascal ABC и выполнить программу. Она сгенерирует случайные веса для учеников, рассчитает средний вес и определит количество учеников, чей вес не превышает среднего. Результаты будут выведены в консоль.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
