Вопрос задан 24.03.2021 в 21:37. Предмет Информатика. Спрашивает Миняйло Саша.

(99 баллов!) Python Напишите программу, которая находит в массиве минимальный и максимальный из

чётных положительных элементов.Если в массиве нет элементов с чётными положительными значениями,нужно вывести сообщение об этом.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Якимова Мария.
mas = [int(i) for i in input('Введите массив : ').split()]
flag = 0
for i in mas:
    if i%2 == 0:
        max = min = i
        flag = 1
        break
if flag == 0:
    print('Четных нет!')
    exit()
for i in mas:
    if i%2 == 0 and i > max:
        max = i
    if i%2 == 0 and i < min:
        min = i
print(max,min) 
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать такую программу на Python. Вот код для решения вашей задачи:

python
def min_max_even_positive(arr): min_val = float('inf') max_val = float('-inf') found_even_positive = False for num in arr: if num > 0 and num % 2 == 0: found_even_positive = True if num < min_val: min_val = num if num > max_val: max_val = num if not found_even_positive: print("Нет чётных положительных элементов в массиве.") else: print(f"Минимальный чётный положительный элемент: {min_val}") print(f"Максимальный чётный положительный элемент: {max_val}")

Здесь мы проходим по каждому элементу входного массива, проверяем, является ли он положительным и чётным. Если да, то мы обновляем минимальное и максимальное значения соответственно. Если мы не найдём ни одного чётного положительного элемента, мы выведем сообщение об этом.

Чтобы протестировать эту функцию, вы можете вызвать её с каким-нибудь массивом, например:

python
arr = [1, 2, 3, 4, 5, 6, 7, 8, 9] min_max_even_positive(arr)

Это выведет:

Минимальный чётный положительный элемент: 2 Максимальный чётный положительный элемент: 8

Если бы в массиве не было чётных положительных элементов, мы бы получили сообщение:

Нет чётных положительных элементов в массиве.
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос